Configuration Help Please!

I can send e-mail from friendica and it arrives here, I can send e-mail back and it shows it coming from rather than So it looks like it has the correct node name even though it did not delete the database.

Once again, I asked you a question which you did ignore.

RAILS_ENV=production bundle exec rake db:drop db:create db:migrate does, always, drop the database. If it can’t, it throws an error. So you either did not run it after fixing the config, you switched the database.yml to a different database without restarting diaspora*, or you’re not showing us an error you see when running that command.

Either way, you now have federated a broken profile across the internet, which means you’ll not be able to use that username+hostname combination ever again in a working setup, because fixing your setup requires you to drop the database, at which point you’ll lose the private key for your account. And without fixing your setup, you’ll never receive incoming federation reliably, because /.well-known/host-meta.xml literally points to localhost.

It does so I guess I am just fuxored then? There is no way I can save the private key, drop the database, then restore it?

It’s 5am here, I’ve had enough for today.

Sorry, I was still replying to your previous message when you posted this one. I did not ignore it, I simply did not see it until I sent the prior. Yes, I have this being proxied through Apache and do have caching enabled on Apache. However, I downloaded the xml file to my workstation here and got the localhost:3000 rather than the external host.

This is what I got:

<?xml version="1.0" encoding="UTF-8"?>
<XRD xmlns="">
  <Link rel="lrdd" type="application/xrd+xml" template="https://localhost:3000/.well-known/webfinger.xml?resource={uri}"/>

Do not do that. Our example configs include caching for static assets, and everything else should not be cached. Never.

This is what I have for the virtual domains:

  RedirectPermanent /

 DocumentRoot /misc/www/diaspora/diaspora/public

 RewriteEngine On

 RewriteCond %{HTTP_HOST} !^diaspora\.eskimo\.com [NC]
 RewriteRule ^/(.*)$ https://diaspora\.eskimo\.com/$1 [L,R,QSA]

 RewriteRule ^/(.*)$ balancer://upstream%{REQUEST_URI} [P,QSA,L]

 <Proxy balancer://upstream>
  # Recommended, using a unix socket (Requires Apache >= 2.4)
  BalancerMember unix:///misc/www/diaspora/diaspora/tmp/diaspora.sock|http://
  # Alternatively let diaspora listen on a local port (Use this for Apache < 2.4)
  # BalancerMember http://localhost:3000

I based this on an example I found on the net.

Looking further, the only caching I have enabled is ssl session.

#          socache_shmcb_module (for default value of SSLSessionCache)
#   Inter-Process Session Cache:
#   Configure the SSL Session Cache: First the mechanism 
#SSLSessionCache         "dbm:/usr/local/apache2/logs/ssl_scache"
SSLSessionCache        "shmcb:/tmp/ssl_scache(8192000)"
SSLSessionCacheTimeout  2400
SSLStaplingCache        "shmcb:/tmp/ssl_stapling_scache(8192000)"
SSLUseStapling On

And that’s it, so perhaps your browser caching?

I guess I will just start over in a different domain, I’m the only user on this one at present so not a great