error when running script bundler


#1

installing on ubuntu 18.04 using mysql. getting error when running script bundler “…did not find expected key while parsing a block mapping at line 1 column 1”


(Benjamin Neff) #2

It would be useful to know which file … but it’s most likely you screwed up while editing database.yml or diaspora.yml … the indention is important.


#3

I’m not a serious coder and the example of where to call the mysql database was not at all clear. below if what I did for database.yml:

postgresql: &postgresql
  adapter: postgresql
  host: "localhost"
  port: 5432
  username: "postgres"
  password: ""
  encoding: unicode

mysql: &mysql
  adapter: mysql2
  host: "localhost"
  port: 3306
  username: "username"
  password: "blahblahLZ"
#  socket: /tmp/mysql.sock
  encoding: utf8mb4
  collation: utf8mb4_bin


# Comment the postgresql line and uncomment the mysql line
# if you want to use mysql
common: &common
  # Choose one of the following
#  <<: *postgresql
<<: *mysql
  database: databasename
  # Should match environment.sidekiq.concurrency
  #pool: 25

clarity would be met with gratitude! thank you :slight_smile:


(Dennis Schubert) #4

Short admin note: In the future, please paste your snippets into code blocks. You can create a code block by using three backticks, like so:

47

This ensures that the code stays readable and all the formatting stays in place! I fixed that for you this time, but keep it in mind for future cases. :slight_smile:

From your paste, it indeed looks like you made an indentation error. This line:

<<: *mysql

should be on the same level as the previous lines, so add two spaces in front of it, and it should work!


#5

thank you Dennis that did indeed fix it! Now I think I have everything installed with no more errors during install. using external URL with lets encrypt cert. for 443 serving test html file worked great. nothing diaspora served. I suspect a faulty reverse proxy config. below is my apache2 .conf file. please advise…thank you again!

<Directory /var/www/html/pod.domainname.org/public_html>
    Require all granted
    Options -MultiViews
    AllowOverride All
</Directory>
<VirtualHost *:80>
        ServerName pod.domainname.org
        ServerAlias www.pod.domainname.org
        ServerAdmin dodad@dhgdhhs.net
        DocumentRoot /var/www/html/pod.domainname.org/public_html

        ErrorLog /var/www/html/pod.domainname.org/logs/error.log
        CustomLog /var/www/html/pod.domainname.org/logs/access.log combined
RewriteEngine on
RewriteCond %{SERVER_NAME} =pod.domainname.org [OR]
RewriteCond %{SERVER_NAME} =www.pod.domainname.org
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
 <Proxy balancer://upstream>
  # Recommended, using a unix socket (Requires Apache >= 2.4)
  BalancerMember unix:///path/to/diaspora/tmp/diaspora.sock|http://
  # Alternatively let diaspora listen on a local port (Use this for Apache < 2.4)
  # BalancerMember http://localhost:3000
</Proxy>
ProxyRequests Off
 ProxyVia On
 ProxyPreserveHost On
 RequestHeader set X_FORWARDED_PROTO https

 <Proxy *>
  # Apache < 2.4
  #Order allow,deny
  #Allow from all
  # Apache >= 2.4
  Require all granted
</Proxy>
</VirtualHost>