Having Trouble Running Update


(CSammy) #21

On a side note, please keep the tone professional and refrain from using swear words.


(Eric Wright) #22

My apologies, I’m just frustrated. I can’t reinstall this, or rather, I don’t want to. It took six to eight hours to get it installed in the first place, and I’ve had to reinstall it three times now and each time I do I have to create an entirely new ID because federation doesn’t know how to actually delete accounts from the federation databases.

This thing is running on ruby SOMEWHERE, I need to figure out where it’s actually running it from, maybe that’ll work.


(CSammy) #23

I can see where your unwillingness to reinstall comes from, though I have to say as long as you’re running a custom installation support will always be tricky and costs an unnecessary amount of time for you and for the people helping you.

That being said, I have looked at your linked guide. From what I can tell, it might actually suffice to install RVM as we have detailed in our guide to come significantly closer to our preferred and well-known setup. You should not need to change anything else. This also means you can keep the database as is and don’t need to create any accounts anew.


(Eric Wright) #24

Here is why I couldn’t use your install guide for RVM:

I’m entirely unsure how to fix this.


(Eric Wright) #25

nvm i got it :slight_smile: Thanks


(Eric Wright) #26

Alright, I see this error when I run the command

bin/bundle --full-index

And when I run

gem install unf_ext -v ‘0.0.7.5’

as it requests, it says it installs just fine, but still gives me this error -_-


(Dennis Schubert) #27

If you look at the output, building gems fails:

virtual memory exhausted: Cannot allocate memory

So, uh, either you have to add some swap to your machine, or you have to temporarily shut down diaspora, or mastodon, or something else.

Edit: Just to be clear: this means your server ran out of memory.


(Eric Wright) #28

Yep, got it. For some reason Mastodon is leaking SWAP Memory. I just repeatedly cleared it and it went through fine :slight_smile:


(Eric Wright) #29

update completed and on RVM now :slight_smile: Thanks guys, sorry I gave you all a hard time.


(CSammy) #30

Apology accepted on my part. I am glad we could work it out and you should have far less trouble with future updates, if the community’s experience with our update guides is to be taken as a basis.

Please, though, refrain in the future from statements like

You may have noticed that it was indeed difficult to update due to you not using one of our maintained and updated-as-needed guides to install and update your installation, and you may have noticed your progress as soon as you committed to following them.

Even if it were not an error on your side, voicing your dissatisfaction in such a way is hurtful to the people doing their very best to build and support this software for free in their spare time. As such, again, please be kind to people spending their time helping you, and voice your criticism constructively and helpful, on any free software project you may be involved in or part of in the future. A kind word and an opportunity to improve our project makes our day.

People make mistakes. All of us.


(CSammy) #31

By the way, if you have any suggestions on how to improve the installation or upgrade process, please share them! We are always looking for ways to make this more straight-forward.


(Eric Wright) #32

I understand. I do have to say, I’m certainly not alone in thinking installing and configuring Diaspora is out of the way difficult and confusing, especially for those who might not be linux experts. That’s more a linux fault than it is a diaspora fault to be honest. Here’s where it fell off the wagon for me:

I’m a systems administrator by profession, but a Windows Systems Administrator. I use Linux only for maintaining a few of my personal servers so I don’t get a hand full of experience. But when something doesn’t work exactly as described in the walk-through and it just throws an error, if you don’t know how to 1. Read said error or 2. Correct said error, then the immediate and automatic response is to seek out alternative guides that might be better. I found a guide that worked for me, but it didn’t work when it came to the upgrade (more likely due to my own ignorance of ruby on linux than with diaspora, something I’m even more inexperienced with than linux itself).

As pointed out, the error I received was due to memory loss, which I was able to fix easy enough once I knew what the problem was, but time and time again with linux I find that these guides are lacking. It’s impossible to fully hash out every potential problem that might come along during the installation process, but it’d be nice if it had some (like this memory issue, that wasn’t addressed in the guide and even though my server has the required memory, it was in fact SWAP Cache memory that the issue was, which was being used up by a different process. Even when I killed that extra process Diaspora alone used up most of the Cache memory. So this might be something to look at as a ‘reserve’ requirement for installing Diaspora, see how much SWAP you need to install the system and put it in system requirements in the installation guide).

As for a recommendation, I only have two, and one of which I know is already being diligently worked on by you guys. :slight_smile: <3

  1. There are a lot…A LOT… of modules here which I don’t even know what they are. Instead of fully explaining them, or at least briefly explaining them, the guide just assumes that you know what they are. I think one was icam or something like that, an image hosting feature. I’ve never heard of that before running through the Diaspora config and when I ran my google search on it, it was either not explained anywhere or any explanation of it was extremely convoluted and confusing. Perhaps link off to a site FAQ that explains exactly what each feature is in the configuration document? That’d be incredibly helpful (chances are this is already out there and my dull face hasn’t found it yet…which goes to say, it should probably be linked within the config itself)

  2. The one I think you’re already working on (as a dev team) is an installation ‘script’ which runs through all your features, does as much automatically as can possibly be done, but gives you yes/no/choose questions to make the process of installation itself easier and less confusing. Mastodon has something like this, it made its installation much MUCH easier. It took me nearly five hours to run through that config the first time, there’s just so much there and it’s so confusing to a new podmin. Granted you guys go far out of your way and give so much of your time to help morons like me out, that makes it much much better.

For the record to any other users who may be reading this thread, I do want to iterate how much I absolutely love this software, it’s not BS, it’s very well written (otherwise I wouldn’t have 300+ new members registering on my platform already) and the support here actually is phenomenal. I think, in this instance, the only reason I was so ‘put off’ was because I’d already been through my own issues three times to get this working, and wasn’t ready to do it again. Thankfully, it wasn’t horrible for me to get it up and running this time around.

Anyway, I’ve rambled on enough. I hope my suggestions help, and I’ll read back over this thread and take in your own considerations to me. Again, sorry for giving everyone such a hard time.