Help! Setup a pod on OSX High Sierra


I’m new here. I want to setup a own Pod, using a macmini i7 (2011) with a clean installed High Sierra. Most of the thinks from the wiki works, but I stuck on this point:

Fix nproc in script/configure_bundler

Mac OS X doesn’t have nproc , so in script/configure_bundler replace it with sysctl -n hw.ncpu

replace config(“jobs #{nproc}”) with config(“jobs #{sysctl -n hw.ncpu}”)

Where i can find this script/configure_bundler?

I’m not to a progger, I’m fine with copying command lines and paste it in terminal.

If a pro user is here and can help via teamviewer it would be perfect.

Thanks for all answers.


The nproc problem on mac is fixed since version (since over a year). So unless you try to install a very outdated version of diaspora, you shouldn’t need to change anything in that script, just run it without changes.

ok thx so i can skip this step. but i still have some troubles, im stuck at here: cp config/database.yml.example config/database.yml
cp config/diaspora.yml.example config/diaspora.yml

only getting: no such files

i really want to support the diasproa commnuity but its very tricky to setup. Is there no easyer way to install it?

All these files are in the diaspora folder (also script/configure_bundler), so you need to cd to that folder first. All relative paths in the installation guide are relative to that folder.

So the latest problem is i cant start the diaspora server I got your bundle is not up o date. I just update everything but still not working, still same error.

any ideas?