Installing a pod

Hi community,

I was wondering if you could guide me through this. I’m installing a pod on my Ubuntu server. I set up a Postgres database. Now I’m being asked to install Ruby version manager using curl -L | bash … however this is asking me for a diaspora password which I never been asked to set to start with. What should I do ?

Hi, I’m not a technical person, but I have installed things such as RVM on my machine in the past, and one question comes to mind. Is it definitely a diaspora* password that you’re being asked for? When you install packages in this way, you’re usually asked for your administrator password for that machine. Try this password and see if it works. If it doesn’t, and you’re definitely being asked for a specific diaspora* password, post back here and someone more technically minded will be able to help you later.

Hi goob,

yes, it’s not asking me for a root password of the machine. I tried to type it in and it spat out “try again”. I tried again just in case I misspelled it by accident but even after ensuring I’m typing
the correct root password it keeps asking me for a password. And the prompt starts with “disapora password”. But I never set it in a first place.

Then I’m afraid I can’t help you. Someone more knowledgeable should stop by soon enough. You can alternatively try #diaspora on if you want a faster response.

ps: welcome, by the way, and thanks for trying to set up a pod. Sorry to hear you’re having difficulties.

It’s OK. I don’t mind having little trouble installing a pod. I like what Diaspora stands for
and the fact that it is an open-source. In fact, Diaspora is the only social network
I’m OK using. Sooner or later I’m gonna have to learn how to allow my friends who are using Facebook to interact with me through Diaspora pod.


if you have followed the “how to” from the diaspora’s wiki, normally there is no password for the ubuntu’s user “diaspora”, because you have used the command sudo adduser --disabled-login diaspora .

Currently if you are connected as another one user, use sudo -iu diaspora

I’m having difficulties with validating signatures:

mark_loves_python@diaspora:~$ sudo gpg --keyserver hkp:// --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 7D2BAF1CF37B13E2069D6956105BD0E739499BDB
gpg: WARNING: unsafe ownership on homedir '/home/mark_loves_python/.gnupg'
gpg: key 105BD0E739499BDB: 5 signatures not checked due to missing keys
gpg: key 105BD0E739499BDB: "Piotr Kuczynski <>" 5 new signatures
gpg: key 3804BB82D39DC0E3: 105 signatures not checked due to missing keys
gpg: key 3804BB82D39DC0E3: "Michal Papis (RVM signing) <>" 59 new signatures
gpg: no ultimately trusted keys found
gpg: Total number processed: 2
gpg:         new signatures: 64

then I run: curl -L | bash
and I get:

 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   649  100   649    0     0    923      0 --:--:-- --:--:-- --:--:--   923
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   194  100   194    0     0    602      0 --:--:-- --:--:-- --:--:--   600
100 24168  100 24168    0     0  62774      0 --:--:-- --:--:-- --:--:-- 62774
gpg: Signature made Thu 03 Jan 2019 10:01:48 PM UTC
gpg:                using RSA key 7D2BAF1CF37B13E2069D6956105BD0E739499BDB
gpg: Can't check signature: No public key
GPG signature verification failed for '/home/diaspora/.rvm/archives/rvm-1.29.7.tgz' - ''! Try to install GPG v2 and then fetch the public key:

   **# the below is the command I used to import 64 signatures**

    sudo gpg --keyserver hkp:// --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 7D2BAF1CF37B13E2069D6956105BD0E739499BDB

or if it fails:

    command curl -sSL | sudo gpg --import -
    command curl -sSL | sudo gpg --import -

In case of further problems with validation please refer to

just for the record. I run the sudo command off the diaspora account as instructed in the tutorial. non-sudo commands I run within diaspora account.

I’m unable to proceed from this. Any ideas ?

Change the permission of all files in your ~/.gnupg directory to 640 for all files and 750 for all folders, oh, and run the gpg command without sudo.

1 Like

Unfortunatelly I don’t use rvm but rbenv for my rubby installation.
But, in the ouptu that you pasted, it writes that you need to install gpg v2.
Which version do you use?

you can run this command : gpg --version

Your solution worked ! File permissions kept me stuck. Thank you so much for your help !