New pod, uninitialized constant Rack::SSL (NameError)

I’m getting the uninitialized constant error in my stderr log every time I run the server, on loop. The server continually crashes and restarts. The full error is:

/home/diaspora/config/initializers/enforce_ssl.rb:8:in ‘<top (required)>’: uninitialized constant Rack::SSL (NameError)

Ok, so I ran gem install rack-ssl and that seems to have killed that error, but now I’m running into other errors that seem to have to do with ActivityPub?
(I didn’t even know Diaspora supported AP)

This is my production.log^^

Did you follow our installation guides? Because if you setup diaspora in production mode, it should already install rack-ssl, you shouldn’t need to install it manually, and if you need to, I don’t know what else is missing.

Are you trying to mix diaspora with mastodon on the same host without properly separating redis/sidekiq? Because it looks like diaspora is trying to process data from mastodon (which obviously doesn’t work because diaspora isn’t mastodon and doesn’t know what to do with it), and probably also mastodon trying to process jobs from diaspora which ends in a big mess.

I did run the guide correctly, but it does seem to be an issue with improper separation of mastodon and diaspora. How does one do that?

In diaspora.yml you want to set a redis to a different database. This doesn’t need to be an entirely separate Redis server, specifying a database different to the default (which is 0) is enough.