Server up and running...but not working?

I figured I needed to create a new topic since technically it’s a new install.

I scratched my entire server, started from scratch. Just followed this tutorial step by step with no issues, and my node isn’t showing up. I’ve checked to see if it’s running, and it is but my domain ( is not loading squat at all. Literally the only difference I did was I used the 2.5.1 version of ruby instead of 2.4.3, since it’s been quite some time since it’s been out, and I replaced his domain name info with mine in all configs. Other than that, exactly the same.

I will also note, this guy didn’t put the # ./script/server command in the instructions, which I figured out on my own. Still not working though, I could use some help…

If you dropped your previous database, all usernames you had in there can’t be reused, because some pods already know the old users from the old database and won’t accept a new one with the same username.

It looks like you didn’t put the nginx config to the right place or didn’t reload/restart nginx afterwards. Also do you want to use or now? Because you already wrote which then would end in diaspora-IDs like You need to decide this before you create your first users.

Also the guide you linked doesn’t use script/server, it uses systemd to start diaspora (which is also described in the wiki), when you then start diaspora with script/server too, you would start it twice, which wouldn’t work.

Ugh, we shouldn’t use systemd for anything. Nobody should.

1 Like

I would actually want without the www for those, but for the domain itself when someone browses there, would it be best to do with the www, or not have it at all in any scenario?

I agree. I actually hadn’t ever heard of it before then tbh.

When you want without www, your pod and webserver also needs to be configured without www, so just

Systemd is great and uses a lot less resources than eye (which is what script/server uses) by doing the same thing (starting and monitoring/restarting the different diaspora processes). script/server is mainly a workaround for systems without systemd and for local development. So when you have a system with systemd, it’s better to use systemd instead of script/server.

ok, I got it up and running again. now I don’t get a 500 error when editing my profile; however, from I’m unable to find myself on my pod.

I think this username@podname.suffix format was one of the driving reasons why I initially wanted to use a domain with no www. for my pod at cryptospora. But then I realized all the pods in the pod “listings” were using www and mine was like the only non-standard one there, so I changed. Now, using internal mod_rewrite, I have actually succeeded in allowing users to have accounts while still being able to access the site via www and federate properly. Cryptospora actually may be unique in that sense, I suppose.

I also remember having to mess with the “finger” system at some point, let me check my notes…

Probably because you reused your old username again. As I already said, when you dropped your old database, you can’t re-use any of the usernames which existed there. already knows your old username and won’t accept the new users with a new key.

ohhh, that I did. derp.

ok, I used, and that worked; however, on I see both people followed each other (in family aspect), but in, it doesn’t say that is following my

Edit: I’m unable to make any more posts as a “new person” and must wait 8 hours, so I’m just editing now so you see the message. Hope you read this.

Awesome, got it :smiley: now shares with I need to go back in and fix up the chat, as that isn’t working, but I think that’s only a few configurations :smiley: if you guys can, let me know if I screwed anything else up. So far so good, not a bad go for my first time hosting my own pod :smiley:

You again mixed www and non-www somewhere, you pod announces all URLs with www, which then doesn’t work. So doesn’t know where to respond. What did you set in the diaspora.yml for url: This needs to be as mentioned before:

But when you change this now you again need a new users to test if it works.

As per @shawneric’s request via the moderation system, I am closing this thread.