Twitter integration missing files/directories


(Olav Folland) #1

I’m trying to set up Twitter integration on my pod to make my Twitter junkie SO happy, and it appears that my install didn’t include the necessary auth components required to connect.

Specifically, when I try to log in to the Twitter service, I get a 404 at ‘’‘https://your_pod/auth/twitter’’’

In the Twitter app setup, I’ve included ‘’‘https://your_pod/auth/twitter/callback’’’ in the Twitter app setup as listed in the diaspora* FAQ.
Twitter is enabled and keys entered in diaspora.yml. (I’ve copied them twice)
For fun, I precompiled assets again.

But, I think it boils down to /home/diaspora/diaspora/auth does not seem to exist at all, nor can I find an /auth directory anywhere else in the structure. Is there a script that I can’t find that needs to be run, or have the paths changed from what is in the FAQ? I know the latter is out-of-date, but…


(Benjamin Neff) #2

Did you correctly enable the service in the diaspora.yml and then restart diaspora? The /auth/twitter route is only available if the service is enabled.


(Olav Folland) #3

Is there something I need to change beyond

OAuth credentials for Twitter

twitter: ## Section

 enable: true
 key: 'consumer api key'
 secret: 'consumer api secret key'

I have diaspora* running as a service, and I’ve tried restarting it there, and separately stopping the service and running script/server, stopping that, and restarting the daemon.


(Benjamin Neff) #4

That should be everything you need to change. If you then restarted diaspora, you should have this route. If it still doesn’t work, can you check if there is something in the logs when you start diaspora or when you try to access /auth/twitter?


(Olav Folland) #5

It say’s there’s no there, there :confused:

Rails: Started GET “//auth/twitter” for [my ip]
Rails:
Rails: ActionController::RoutingError (No route matches [GET] “/auth/twitter”):

And indeed, there is no such directory ‘auth’


(Benjamin Neff) #6

Why is there a double //? The route //auth/twitter actually isn’t defined and doesn’t work, try it without the double / at the beginning.


(Olav Folland) #7

I have no idea whatsoever on where I would change that, nor where to start looking if there’s a config problem somewhere else.

Shouldn’t the path be more like /home/diaspora/diaspora/auth/twitter though?


(Benjamin Neff) #8

There is no file/folder with this name, the route is dynamic, if the twitter service is enabled, but it only works with one /, not with a double //. If you don’t have the // in the browser, check if your reverse-proxy adds a slash somewhere.


(Olav Folland) #9

Now I’m in way over my head. I’ve run static- and wordpress- type websites for years, but never delved into proxies.

If it helps, my apache2 .conf is modeled after the jhass template https://gist.github.com/jhass/719014 which if it is incorrect, I wouldn’t know. Everything else on the pod seems to be running fine.


(Benjamin Neff) #10

Can you paste your config somewhere? Have you added a / somewhere? Maybe on line 24?


(Olav Folland) #11

Unless I’m blind, (which is possible) that line hasn’t changed.

Posting to one of my wordpress sites dorks the formatting a little, so is there a preferred place?

Edit: pastebin: https://pastebin.com/0qhk2j3h


(Benjamin Neff) #12

That line looks OK, but otherwise the paste looks weird. It misses all the line with <...> and there are a few /path/to/... in there, didn’t you change those? Because the paste is more or less just the example with only the domain changed, but I think that wouldn’t work in that state.


(Olav Folland) #13

::embarassed somewhere last night I started looking at an old conf (diaspora, not bobspora) :roll_eyes:
I think the end result was I hadn’t set up the balancer member line correctly. All good now!

Sorry for the waste- bring up the wrong file in shell once and it persists…

Hopefully you’ll forgive me and I can answer questions for other n00bs :wink: