Watermarked photo displayed in wrong orientation

(Roy The Newbie) #1

I am having a problem when inserting watermarked photos into my pluspora posts.
When the photos are in Landscape orientation there is no problem: however, when I have a watermarked photo in Portrait orientation it is displayed in my post in Landscape mode. This is despite the fact that other Image viewers have no problem in displaying them correctly.

I will also point out that the same photos, if not watermarked, are displayed correctly in my posts. It is as though the watermark itself has some Landscape parameter that the diaspora Composer is latching on to. I use GIMP, in Ubuntu, to do the watermarking. But when I create the watermark there is no Portrait/Landscape selection that I make: GIMP just asks me where I want to locate the watermark text in the image.
I have tried changing the exif data but…no success.
Please advise me if you can. :slight_smile:

0 Likes

(Spc Cw) #2

Could you show an example of such image?

Also try exporting (saving) images without metadata. I am pretty sure it is saved with wrong orientation (perhaps coming from the camera) and web browser just doesn’t respect it.

0 Likes

(Roy The Newbie) #3

Thanks very much for your suggestion: I tried briefly to do what you suggest but have not yet figured out, using Gimp, how to do it.
Here is a link to my last pluspora post that exhibited the problem:

0 Likes

(Roy The Newbie) #4

Ok, I now followed the link that you provided, to the Gimp help article. I followed your instructions and then did a test post on pluspora, just to myself. Unfortunately, it did not work. :frowning:

0 Likes

(Roy The Newbie) #5

Hurray! I think I may have solved it, with your help, of course! I thought, as a wild guess that If I de-selected the XMP option as well, that might do something. IT DID!!! I did a test post in pluspora, just to a personal Aspect, and it worked. The image was in portrait format, as desired, and the watermark was correct.
It’s late now so I cannot investigate further tonight. I shall confirm that this still works tomorrow.

0 Likes

(Spc Cw) #6

Yep, I didn’t think about XMP. Both EXIF and XMP can contain image rotation data (among other metadata) and some applications are either working with it incorrectly or are too lazy to actually rotate images and just set it in meta hoping other applications will follow it. Other apps however sometimes are also too lazy and display the image as it is and some even actively strip any metadata for privacy concerns :slight_smile:

When you post photos you took on the Internet it is generally good idea to remove all metadata. This ensures correct orientation and prevents you from leaking information you probably don’t want to (such as location data, date/time, camera model).

0 Likes

(goob) #7

In case you didn’t realise, there’s an option to strip EXIF from all photo uploads in the diaspora* user settings. I’m not sure whether this also strips XMP, and therefore whether this would solve your immediate problem, but it will strip identifiable meta-data, so is a good option for privacy.

0 Likes

(Roy The Newbie) #8

Yes, thanks, I was already configured to remove EXIF from photo uploads.
I am guessing that XMP data was not stripped through that Privacy setting, as manually stripping XMP has fixed my current problem.

0 Likes

(Spc Cw) #9

I looked into it a bit.

Before editing the file has EXIF rotation set to 270CW (i.e. rotate it to the right three times) and same in XMP.

After GIMP edit the image appears to be physically rotated and EXIF rotation is set to normal but XMP tag remains rotated (bug in GIMP?). This confuses Diaspora and it then turns the image wrong way. Other apps I tried seem to resolve this situation correctly. Maybe they prioritize EXIF and Diaspora prioritizes XMP.

Metadata clearing in Diaspora works correctly - if turned on it clears both EXIF and XMP, if turned off it doesn’t. But it doesn’t affect the result (and this doesn’t seem to be Diaspora’s fault here).

0 Likes

(Roy The Newbie) #10

OK, well thanks for the info. I must admit I do find it all rather confusing. Maybe I should find another Ubuntu app to insert the watermark because it’s really tedious having to go in each time to remove the XMP data. Do you happen to know a simple Ubuntu app that would do insert watermarks without causing this error?

0 Likes

(Roy The Newbie) #11

It has just occurred to me, as an afterthought, that I might be 'misunderstanding" a question I am asked by GIMP.
When the first (un-watermarked and rotated, Portrait format) file is opened in GIMP, what I see in the on screen display is the image unrotated, in Landscape format, and a question saying something like: “GIMP sees that this image is rotated, do you want to rotate it to its normal orientation?”.
If I answer YES the displayed image is rotated to what I want it to be i.e. Portrait orientation. then after the saved watermark is inserted it is in the position that I want.
If I answer NO the displayed image is rotated to what I DO NOTwant it to be i.e. Landscape, then after the saved watermark is inserted it is NOT in the position that I want, but at right-angles to it.

So, obviously, I have been answering YES when asked the question. However, it seems that in doing that I may have been instructing GIMP to remove the EXIF rotation only, thereby introducing the mismatch between the EXIF and XMP rotation data.

It’s just a thought and might be irrelevant…

0 Likes

(Spc Cw) #12

I never had these problems with GIMP and Diaspora (or anything else - but I saw it happening with other people and other apps). I guess it depends on your exact workflow - e.g. it is unclear what exactly inserts this XMP data in the first place, maybe it is the camera or some other app (there are some tags from Shotwell - maybe it introduces these tags, maybe there is some setting in it (or GIMP) to make it not to.

In my GIMP version you can set it in “Edit/Preferences/Image Export” not to save any metadata by default or you can restrict some types of it (e.g. save EXIF but not XMP) - this should work for you.

Anyway I think this is out of scope of this forum and is better taken somewhere they discuss photo editing and/or free graphics software - there you’ll have better chance to learn about best practices and possible gotchas :slight_smile:

0 Likes

(Roy The Newbie) #13

Thanks for all the help you provided: I really appreciate it and have learned a lot! :slightly_smiling_face:

1 Like