Diaspora in Docker making user admin

Hi there, I’m new here and new to using diaspora. I am successfully running @koehn 's docker image but am having trouble running the RAILS_ENV=production bundle exec rails console command so that I can make my user an admin on my pod. When I run it in the diaspora folder it returns this sh: 3: bundle: not found so I am assuming it’s not finding the bundle command in the directory that I am in. I have tried other directories but get the same result. Anyone else run this container that could give me a hand…or a clue?

You need to be in /home/diaspora/diaspora to run the bundle command.

Yup, that’s exactly where I was.

Sorry! I think it’s supposed to be bin/bundle

Now I am getting a /usr/bin/env: 'ruby': No such file or directory

That’s odd. When you cd into /home/diaspora/diaspora rvm should configure the ruby stuff for you. Did you docker exec into a running container?

I believe I did try docker exec but it just did the same thing.

I am on UnRaid, which doesn’t use docker-compose. I manually created the template to get it to run. I’m not sure if that would have anything to do with it.

Docker-compose is a set of Python scripts you can run anywhere, including inside a Docker container. See “alternate install options” here: https://docs.docker.com/compose/install/#install-as-a-container.

So are you saying that it has to be installed via compose? I already have the redis and postgres containers going and Diaspora itself is working just fine, my only problem is trying to make my user and admin of the pod.

Not at all (I’m running on Kubernetes). Just giving you another option if that’s something you want to do.

I’m not sure why rvm isn’t working for you; if I docker exec diaspora /bin/bash I get rvm. I guess that begs the question of how you got into the container? I don’t know for certain if rvm works with e.g., sh.

1 Like

That was it… In UnRaid, there is a button to bring up a “console” window of the container and I bet it was using sh. I just got it working with doing the docker exec /bin/bash. So it was my fault, your container is perfect. You can delete my issue I submitted earlier today on your gitlab site.

1 Like

So glad you got it working! Huzzah!

Thanks again for your help!

1 Like