Diaspora public folder missing web files

Hello all.

Just did a manual Diaspora install, everything appears to be working fine except the webpage doesn’t load. On checking the Diaspora public folder it appears to be missing some web files.
Have i missed something during the complication on install?

Please see my attached image of the directory.

Any help i can get would be greatly appreciated. Thanks.

Had the same problem with a cPanel install. Have decided to go with a cloud install.

diaspora* is not a PHP application, you can’t just throw a bunch of files into a folder and point the webserver at it, unfortunately. diaspora* comes with its own webserver that is responsible for handling all requests, and you use Apache/nginx as a proxy in front of that to connect diaspora*s own webserver to the internet.

Which installation guide did you follow? The guides in our wiki provide example configs for Apache and nginx, and they also explain how to start diaspora*s server, which should get you running.

Note that you can’t install diaspora* on shared hosting - as explained in the install guides, you need shell access, you need to be able to run your own processes, and you need control over the Apache/nginx config files.

Thanks for responding.

I’m running Diaspora in virtual box on Centos 7 and i followed the apache guide. which points to “/home/diaspora/diaspora/public” as document root.

The one I linked, or something else?

Right, but that’s only one line in a fairly large config example. :slight_smile: The public folder is only used for some static files, like the CSS files, but also uploaded images. Everything else is rewritten to be served from diaspora*s server in that config.

Please double-check that you’re using the right config, and everything form it, not just the document_root line. You can also share your apache config here, so we can take a look at that.