Interesting Issue I keep Seeing


(Eric Wright) #1

I’ve been noticing that after I make a post, any post, whether it be a thread or just a comment, it posts successfully, and when I leave the page, I get a pop-up that says my changes weren’t saved, do I really want to continue? I click yes, it reloads, I go back to check if my post was made, and it was. Bug?


(Hank G) #2

I’ve tried reproducing this error just now on my main account pod and my development pod and I’m not seeing that behavior. I don’t recall seeing that behavior at all except when I actually hadn’t posted. Can you provide some more information on the workflow that causes this, browser, pod software version, etc?


(Eric Wright) #3

Sure, I’m on https://diaspsocial.com. Usually I use the most updated version of Chrome browser on Windows 10 64 bit. This error is given to me anytime I create a new post at all, regardless of whether it’s the initial post or if it’s a comment on another post, regardless of whether it’s on my post or someone else’s post, even federated posts.

The error is simply the message you should expect to get if you hadn’t completed your post yet and you clicked to cause that specific browser window to go to a different page or to leave your incomplete post; however, the post is complete, and has been posted already, so it shouldn’t be giving me this popup. After I click “stay” or something to that effect, it goes it’s way and if I double check, the post is in fact posted.


(Eric Wright) #4

Here you go, it’s happened again.


(goob) #5

Have you tried a different browser? That might help identify whether the issue is caused by the browser (or one of its add-ons) or by the OS.


(Hank G) #6

I’ll try to reproduce it on a Windows 10 VM I have kicking around…


(Hank G) #7

I just installed the latest Chrome in a Windows 10 VM (fresh install of Chrome) and have not been able to reproduce this problem. I originally tried it on my usual pod but when that failed to produce it then also created a new account on DiasporaSocial and tried this as well, both in the standard default theme and with the dark theme which I think is what is in the screenshots (not that the theme should change the behavior but why not check all bases). Under no scenarios was I able to produce this behavior on primary contents on the timeline, comments on posts on the timeline, or comments on a post in the single post view in the screenshot. Do you have any plugins or is there some customization that I maybe didn’t get picked up with a new account?


(Eric Wright) #8

I don’t really have any other plugins with the standard D* installation. It “could” be an account issue, that’s true. If no one is able to recreate this problem, then I suggest we just let it rest until someone else complains about it. It appears to not be a bug and is just a problem on my end. :slight_smile:


(goob) #9

I don’t know whether this will help, but four steps I can think of that might be worth trying:

  1. Sign out of diaspora* and back in.
  2. Delete diaspora* cookies.
  3. Delete cache.
  4. Re-install the browser.

Hopefully one of those will reset whatever is unset. I speak as a rank amateur, so this might all be nonsense.