Is the official Wiki Borked?


(Paco) #1

Hi guys. I was gonna contribute by editing the wiki. I had to register an account on the wiki. When I tried to confirm my email, I saw an error message:
diaspora* project wiki could not send your confirmation mail. Please check your email address for invalid characters.

Mailer returned: Failed to connect to ssl://mail.0b101010.org:465 [SMTP: Failed to connect socket: Connection refused (code: -1, response: )]

So I don’t have a Wiki account yet and I don’t think I can fix this. So I decided to go click on “About” on the wiki and see if there were some contact details. I don’t know who to report wiki problems with or how to find that out. Well, clicking on https://wiki.diasporafoundation.org/Diaspora_Wiki:About (which is a link at the bottom of every page on the wiki, tells me that the page was deleted 4 years ago.

This page has been deleted. The deletion, protection, and move log for the page are provided below for reference.
    11:11, 25 September 2014 Jhass (talk | contribs) deleted page Diaspora Wiki:About

So I figured posting here would get some attention. Sorry to do it that way, but I just don’t know how to find the right front doors for stuff. I’m trying to help, guys, but it’s not easy.


(Dennis Schubert) #2

Ah yeah, there were some technical difficulties after a migration of the mail server, I’m sorry. It works now!


(Paco) #3

You sure about that? I clicked the “send a confirmation” button and I even changed my email address and clicked it again. I got no errors, but I didn’t get any email either.


(Dennis Schubert) #4

Yes.

Assuming your username is Grumpy-podmin in the wiki, your email server fails when attempting to validate DMARC:

host mx0b-00146301.pphosted.com[67.231.156.147] said: 451 4.7.5 Temporary error evaluating DMARC policy (in reply to end of DATA command)
to=<dXXXi@fXXX.pXXX.to>, relay=mx0a-00146301.pphosted.com[67.231.148.148]:25, delay=164071, delays=164066/0.03/3.3/1, dsn=4.7.5, status=deferred (host mx0a-00146301.pphosted.com[67.231.148.148] said: 451 4.7.5 Temporary error evaluating DMARC policy (in reply to end of DATA command))

The only thing your server may be able to validate is the SPF record, which is valid and would pass. Given that the outbound wiki mails have no DMARC, or DKIM signature in their DNS zones, your server has an issue and I highly doubt there is anything I can do.