Precompiling fails with exception using procedure from official wiki

Hello everyone!
I’m following the procedure from the official wiki to make a diaspora pod out of a Raspberry Pi 3:
However, when I get to the precompiling part, I get an exception. You can find the stack trace here:
I am using the latest release of Raspbian, which is based on Debian 9.

Let me know how I can help.

It looks like execjs is failing. Do you have “one of the JavaScript runtimes on execjs’ supported list”? The wiki tells you to install nodejs.

Thanks for your help, yes nodejs is installed:

diaspora@tdd1:~ $ apt list nodejs
Listing... Done
nodejs/stable,now 4.8.2~dfsg-1 armhf [installed]

I tried to repeat the installation from scratch, but unfortunately I incur in the same error.
At the end of the trace log, I get repated mentions of “sprocket” and “sprocket-rails”- I know nothing of Ruby, I guess they’re libraries which somehow fail to compile?

I report here the last two lines of the trace:

/home/diaspora/diaspora/vendor/bundle/ruby/2.4.0/gems/sprockets-3.7.1/lib/rake/sprocketstask.rb:147:in `with_logger'
/home/diaspora/diaspora/vendor/bundle/ruby/2.4.0/gems/sprockets-rails-3.2.1/lib/sprockets/rails/task.rb:67:in `block (2 levels) in define'

I don’t know if nodejs 4.x is enough, I have nodejs 6.x on my pod (which is also already pretty old, but still supported), so you could try with a newer nodejs version.