Reinstalling/upgrading: no ruby 2.6

I’m reinstalling/upgrading (from a complete saved archive & database) and get to this point and the below happens.

diaspora@0.darwinheim:~$ rvm install 2.6
Unknown ruby string (do not know how to handle): ruby-2.6.
No binary rubies available for: unknown/libc-2.33/armv7l/ruby-2.6.
Continuing with compilation. Please read 'rvm help mount' to get more information on binary rubies.
Checking requirements for unknown.
Install: build-essential libreadline zlib1g libyaml libc6 libgdbm ncurses
Requirements installation successful.
Installing Ruby from source to: /usr/local/lib/diaspora/.rvm/rubies/ruby-2.6, this may take a while depending on your cpu(s)...
ruby-2.6 - #downloading ruby-2.6, this may take a while depending on your connection...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0   300    0     0    0     0      0      0 --:--:--  0:00:10 --:--:--     0
curl: (22) The requested URL returned error: 404
The requested url does not exist(22): ''
Checking fallback:
No fallback URL could be found, try increasing timeout with:
    echo "export rvm_max_time_flag=20" >> ~/.rvmrc
There has been an error fetching the ruby interpreter. Halting the installation.

Try updating your rvm to the latest dev-version with rvm get master, then install 2.6.10 explicitly with rvm install 2.6.10.

The first command worked but the second is still saying nothing after several hours–how long should it take?

It should take minutes. It’s not outputting anything at all, just silence?

I said it’s saying nothing which is the same as saying it’s not outputting anything at all, just silence.

Looks like your RVM is somehow borked, and I cannot reproduce that in my setup. The RVM folks at Issues · rvm/rvm · GitHub are probably the best to help diagnose your setup.

Obviously some things might be different when upgrading, and that should be documented. I went through some of the installation steps again and this time it worked.