Reinstalling/upgrading: various problems

I upgraded from old 0.7.n to 0.7.16.0.

Warning: the gem 'rails-assets-bootstrap' was found in multiple sources. Installed from: https://gems.diasporafoundation.org/ Also found in: * https://rubygems.org/ . You should add a source requirement to restrict this gem to your preferred source. For example: gem 'rails-assets-bootstrap', :source => 'https://gems.diasporafoundation.org/.' Then uninstall the gem 'rails-assets-bootstrap' (or delete all bundled gems) and then install again.

Starting Redis server... Required ruby-2.6.6 is not installed. To install do: 'rvm install "ruby-2.6.6."' WARNING: Project gemset is diaspora but you are using ruby-2.6.10 Starting Diaspora in production mode with 1 Sidekiq worker(s).

Someone here said install 2.6.10.
     After this I get proxy webserver internal server error.
     If you can help me fix my node, I’ll restart a node I let a few scientific/mathematical people use.