What's the best platform for diaspora?

Hey guys, making a VM to run just diaspora and nothing else. Which platform is the most native/supported? I figured Ubuntu (20.04.5 LTS), but I keep getting errors and crashes even though I followed the guide to a T.

Logs show errors like:
Top level ::CompositeIO is deprecated, require ‘multipart/post’

Again, I don’t necessarily care to get support for the errors if I can just use another platform that may work better or more natively.

Ubuntu, Debian, Fedora, CentOS, Gentoo, Arch, openSUSE, or MacOS?

That should work just fine.

That’s just a warning and not an error and you can simply ignore it.

If something else isn’t working or you get errors somewhere, then we would need more information.

1 Like

Oops, I was checking the wrong log file… Turns out the other, not the err but the out log, said my db password was wrong. It was a db setup issue! :slight_smile:

Thanks for the quick reply, made me find the issue. Sticking with Ubuntu then.

I couldn’t get it to run in Ubuntu and found more luck in Fedora. I’m running into an issue now on Fedora where I can’t run bundle install without CA certificates. I tried editing the gemfile changing the url to http but the error continues while showing the url as http. haha Tried restarting after.

I’m now trying to get CA certificates on Fedora in order to run bundle install…

Any ideas? I generated a cert from my NginxProxyManager and transferred all 4 files to /etc/pki/ca-trust/source/anchors/, then ran update-ca-trust but the issue persists. As far as I can find I can’t install Lets Encrypt on fedora 22 as it’s outdated.

Is there a force install without this cert check?